in reply to this object

I ended up just saying fuck it, and used KVM lmao

I'm glad has both!

I deleted a VM in , and until I logged out of SSH and back in. I got this error when running vmadm

$ vmadm list Uncaught Error: EIO, i/o error FROM Function.startup.resolveArgv0 (node.js:811:23) startup (node.js:58:13) node.js:902:3 Abort (core dumped)

(Don't worry, my future bugs of the days won't always be SmartOS, it's just what i'm using heavily right now lol, seriously, I love SmartOS!)

I'm gonna start doing a "Bug of the Day" kind of thing. Where when I encounter a bug. I'm gonna post what it was, and how I solved it. For my first one:

instance doesn't allocate enough space for a indestructible snapshot like it does with a instance. Definitely not intentional.

Solution: Add another gigabyte to it's zfs filesystem.

Now watch as I never post something like this again =P

Finally got NAT working on my hypervisor. The bulk the time spent was dhcpcd not getting the gateway correct in a VM and me trying to figure that out until ChatGPT (Yes, I got that desperate) was like "Check route -n), and that's when I saw that the gateway was =P

So, I recently discovered that the SSDs in my homeserver could self-encrypt, and after using sedutil I had full disk encryption that was independent of the OS. Because of that, the last and biggest thing holding me back from switching to was solved (Full Disk Encryption). So now i'm migrating all my stuff from my jury-rigged linux server to it.

So far, it's been as simple as dding image files into a zfs volume, and using the awesome tools that comes with SmartOS.